Pages

Wednesday, March 2, 2011

Adding a 2nd harddisk to a SunFire V100

I have a SunFire V100 with a 40GB IDE harddisk and 2GB of memory (I found this poor machine in the internet for 50€). Today I decided to add a 2nd 40GB harddisk. The harddisk is left from my old workstation and should work perfectly with the system.
It doesn't. The system even didn't recognize the harddisk. After doing some research on the internet I found out that most Sparc Systems with support for IDE only recognize the IDE harddisk when the
harddisk jumpers are set to Cable Select. So I jumpered the harddisk to Cable Select and surprise - works perfect:

# iostat -En
c0t0d0           Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
Model: IC35L060AVV207-0 Revision: V22OA66A Serial No:       VNVB02G2ED
Size: 41.17GB <41174138880 bytes>
Media Error: 0 Device Not Ready: 0  No Device: 0 Recoverable: 0
Illegal Request: 0
c0t2d0           Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
Model: ST340014A        Revision: 3.04     Serial No: 5JX6TJRV        
Size: 40.02GB <40020664320 bytes>
Media Error: 0 Device Not Ready: 0  No Device: 0 Recoverable: 0
Illegal Request: 0
c0t3d0           Soft Errors: 2 Hard Errors: 0 Transport Errors: 1
Vendor: TEAC     Product: CD-224E          Revision: P.9A Serial No: 
Size: 0.00GB <0 bytes>
Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
Illegal Request: 2 Predictive Failure Analysis: 0

c0t2d0 and c0t3d0 were built in. c0t0d0 was added by me. Now I wonder: I have here two other 500GB disks, will they work? And IDE supports 4 disks, and there seems to be enough space in the V100 for 3 disks. Maybe it will work...